Bulk Upload, not all columns being displayed after Trial Run

Bug report template

In which Wildbook did the issue occur? ACW

What operating system were you using? (eg. MacOS 10.15.3) Win 10

What web browser were you using? (eg. Chrome 79) Chrome Latest

What is your role on the site? (admin, researcher, etc) Logged in as Researcher

What happened?


What did you expect to happen?
All columns should display to confirm upload ?
What are some steps we could take to reproduce the issue?
I will send XLS file by separate email

ALso, system not displaying/loading Longitude field ?

Hey @PaulK,
Based on the first screenshot, it appears the in-line scrollbar is present. Were you not able to adjust to scroll to the right?
Thanks,
Tanya

Hi Tanya

I was able to scroll and the last Column is the one showing in Yellow which is flagged below re Photographer

Thanks

Paul

Hello,

Of the two columns mentioned here, I know we have talked in other threads about the Encounter.photographerX fields, and when they get accepted or rejected. Let me know if this case is
different or any further information is needed.

For the Encounter.decimalLongitude field, I have tested the file ACW_upload_Tico_02-08-2017_07-35.xlsx on my local computer, on a development machine and as far as the trial run on ACW and not been able to replicate longitude’s absence from the feedback. I have observed this behavior infrequently with other import columns on other Wildbooks however.

As far as I can tell, the error is in the tabular feedback alone. While not ideal, closing the tab you have used for the trial and simply trying again seems to overcome it in most cases. Due to it’s intermittent and infrequent nature it is very hard to debug, but know that we are tracking it, have observed it and will apply a fix as soon as we are able.

In general, when a column is rejected because of a data issue you will still see a stub in the feedback with the cells highlighted in blue, yellow or red as appropriate.

If the column is not present in the feedback at all give it another try in a new tab or browser window. If you witness it multiple times consecutively for the same file go ahead and send me the file and I will try to replicate it.

Thanks.

Hi Colin

Finally back on these uploads and have another instance of columns not being reflected in the table at the pre-commit stage.

Ignoring the Photog Fullname (dealt with elsewhere) the 2 fields of concern are OccurrenceID and decimalLongitude - just not showing at all.

Info at bottom of table indicates all columns in spreadsheet captured… ?

Should I commit though ?

XLS file is here:

Thanks

Paul

PS: I have since done a commit on a similar bulk upload and altho the Columns are not showing they are going thru into the system correctly. Thanks, Paul

Thanks for updating this. I was able to make a small change based on the file you provided that should catch a few more cases of the columns not displaying properly. It doesn’t guarantee this won’t happen again for other formatting, but the change fixed the issues particular to this file and the noted columns all displayed in my tests.